これから Nishiki Pro
テーマを使うなら1度は確認しよう!

Nishiki テーマおすすめ設定 テーマおすすめ設定を見る
  1. ホーム
  2. マニュアル
  3. 「このテーマは現在使用中の PHP のバージョンでは動作しません。」と表示されてワードプレステーマがインストールできない時に読むページ

このページでは、入手したワードプレステーマをインストールする際「このテーマは現在使用中の PHP のバージョンでは動作しません。」と表示されてインストールできない時の解決方法を案内しています。

解決方法:サーバーの PHP のバージョンを上げてください

現在使用しているサーバーの PHP のバージョンを確認してください。

ワードプレスの本体のバージョンが 5.1 以上で、サーバーの PHP のバージョンが古く、テーマが必要とする PHP のバージョンに満たしていない場合「このテーマは現在使用中の PHP のバージョンでは動作しません。」と表示されるようになっています。

サーバーの PHP のバージョンが古いと
テーマがインストールできない場合がある

PHP のバージョンを上げる方法

巷の主要なレンタルサーバー会社などでは、PHP のバージョンを上げるためのコントロールパネル(管理画面)が存在します。コントロールパネルにログインし、バージョンを上げてください。

注意!!

PHP のバージョンの上げ方がわからない場合は、ウェブサイトの運営に詳しい担当の方や、レンタルサーバー会社に問い合わせましょう。

PHP のバージョンを上げると、使用しているワードプレス本体/テーマ/プラグインすべてに影響が出ます。

例えば、サーバーの PHP のバージョンを 7.4 に上げたとします。

使用しているワードプレス本体/テーマ/プラグインすべてが PHP 7.4 に対応しているかどうか、必ず確認してください。未対応の場合、ウェブサイトの閲覧や管理画面の操作などができなくなる場合もあります。十分注意してください。

ところで PHP のバージョンを上げる理由ってなんなの?古いとダメなの?

以下のページにまとまっていますので、必ず読んでください。大事なことがたくさん書かれています。

WordPress テーマ Nishiki Pro

「ウェブサイト運営に本当に必要とされる機能」をテーマ内にまとめて搭載した WordPress テーマです。

ブロックエディター機能を強化し、これまでの WordPress では難しかったコンテンツが簡単に作れます。

ブログ、ポートフォリオ、コーポレートサイト、ビジネスサイトなど、様々な目的のウェブサイトに対応できるテーマです。

最新情報をチェック!

Nishiki / Nishiki Pro テーマに特化した情報を「にしきちゃん」がお伝えします😀

  • リリース情報
  • 新機能の紹介
  • 便利な使い方
  • 開発中の機能紹介
  • 導入事例
  • あるある日常ネタ

など

著者

Imamura

東京都北区十条にあるウェブサイト(ホームページ)制作会社 AnimaGate(アニマゲート) という会社をやっています。サポトピアでは自社製品・サービスの全般的な開発・管理などを行っています。これまで数多くのウェブサイトの新規作成・リニューアル・運営などを経験し、WordPress(ワードプレス)公式サイト登録済みテーマやプラグインなど、ウェブサイト運営に役立つ様々なツールを開発・公開しています。サポートの一環として YouTube のライブ配信などオンラインサポートを試験運用しています。ぜひチャンネル登録いただけると大変嬉しいです。→ブログはこちら

他のマニュアルを見る

WordPress(ワードプレス)の使い方

マニュアルTOPへ戻る